Posts

Showing posts from February, 2010

Sentinel.v3.5Client and Windows 7

When trying to install applications created and deployed with .NET ClickOnce on Windows 7 you may get the following error:
"Unable to install or run the application. The application requires that
assembly Sentinel.v3.5Client Version 3.5.0.0 be installed in the Global
Assembly Cache (GAC) first."This is an issue with build 7057 (and maybe 7000) and the way that the .NET Framework was installed. Asking around the internet will generally give the impression that you need to install .Net Framework 3.5 SP, or that your copy is damaged. It's not.

The issue is exactly what the error message says, that the Sentinel.v3.5Client assembly is not installed into the Global Assembly Cache (GAC). It's a simple fix with a few steps.
Step 1: You need to locate the Sentinel.v3.5Client.dll file on your system to make sure you have it. I located mine in %systemroot%\Microsoft.NET\Framework\v3.5
Step 2: You will need the gacutil.exe utility. This file can exist one of more places on your syst…